
Using Simulator With 

Undertow Suite



• Source environment variables

For example, envsource has all the environment variables set up. 

You can change the paths accordingly.

------------envsource file contents-------------------------------

setenv VCSI_HOME <path where VCSI is installed>

setenv DEFAULT_VCS_HOME <path where VCSI is installed>

setenv VCS_HOME <path where VCSI is installed>

setenv TMPDIR /tmp

setenv VCS_NETHOST vt1

setenv VCS_LTD_LICENSE 1

setenv VCS_CC cc

• vtplivcs.o and vt_vcs.tab are present in our PLI directory

STEPS FOR SIMULATING USING 
VCS:



VCS contd.

• <source> is the file that contains the source code files for Simulation

• To make the source file: add iv.v (found in our distribution directory) at the top with 
top level file next followed by all the .v files needed in simulation.

• Contents of  iv.v file

// iv.v 

module vtInteractive;

initial

$vtIv;

endmodule



VCS cont.

• Add to source code close to top module

initial

begin

$vtDumpvars();  /*dumps everything - created by our PLI routine.*/

$vtTrace(1) /*enables event tracing of your complete design*/

end

• In the example(in our distribution directory), the above has been inserted in 'top.v' file.



VCS cont.

• To compile through the simulator in interactive mode do as follows:

vcsi <flags> -f source $UT_ROOT_DIR/PLI/vtplivcs.o –P 
$UT_ROOT_DIR/PLI/vt_vcs.tab

• For example,

./run_vcsi_int

-------run_vcsi_int contents-----------------------------------

#!/bin/csh –f

vcsi -Mupdate +vpi +cli +acc+2 -lm -line  -f source

$UT_ROOT_DIR/PLI/vtplivcs.o –P UT_ROOT_DIR/PLI/vt_vcs.tab



VCS cont.

• To open the Undertow Suite in batch mode, the command lines is as follows:
ut -iv -f <source> -sigfile <dump filename>
<source> is the file that contains the source code files for simulation
For example,
ut -iv -f source -sigfile fsm.sigs -tracefile fsm.trace

To view just the waveform,
ut -v <signal_file>
For example,
ut -v vt.dump

• To open the Undertow Suite in interactive mode the command lines is as follows:
ut -iv -vcs <vcs_simulator_executable> <simulator_options> -sigfile
<signal_filename> -tracefile <trace_filename> -ivsimcmp "-f <file that lists
all source code file names>“
For example,
ut -iv -vcs simv -sigfile fsm.sigs -tracefile fsm.trace -ivsimpcmp “-f source”



STEPS FOR SIMULATING USING 
MODELTECH

• Sourcing environment Variables 

For example,

./envsource

------------envsource file contents-----------------------------

setenv PLIOBJS $UT_ROOT_DIR/PLI/vtpli_modtech.so

setenv ModelTech <path where ModelTech has been installed>

• vtpli_modtech.so is available in our PLI directory.



MODELTECH contd.

• <source> is the file that contains the source code files for Simulation

• To make the source file: add iv.v at the top with top level file next followed by all the 
.v files needed in simulation followed by “+libverbose” at the bottom.

• Contents of  iv.v file

// iv.v 

module vtInteractive;

initial

$vtIv;

endmodule



MODELTECH contd.

• Add to source code close to top module

initial

begin

$vtDumpvars();  /*dumps everything - created by our PLI routine.*/

end

• In the example(in our distribution directory), the above has been inserted in 'top.v' file.



MODELTECH contd.

• Compile through the simulator as follows:

./run_modeltech

run_modeltech : script for running all modelsim commands.

---------run_modeltech contents--------------------------------

#!/bin/csh -f

if (-e work) then

rm -r -f work

endif

if (! -e work) then

vlib work #creates new design library work

endif

vlog -f source #compiles the verilog files into the work library

vsim -c -do 'run -all' top vtInteractive +VTCOMPRESS250 +VTVECTORVALUES



MODELTECH contd.

• To open the Undertow Suite in batch mode, the command lines are as follows: 

ut -iv -f <source_code_file> -sigfile <signal_file> 

<source_code_file> is the file that lists all the source code files. 

For example, 

ut -iv -f source -sigfile fsm.sigs 

To view just the waveform,

ut -v <signal_file>

For example,

ut -v vt.dump



MODELTECH contd.

• To open the Undertow Suite in interactive mode, the command lines are as follows:

• ut -iv -modeltech <simulator_executable_name> <top level module names> 
<simulator_options> -sigfile <signal_filename> -ivsimcmp “-f<file that lists all source 
code files>”

For example, 

ut -iv -modeltech vsim top -sigfile fsm.sigs -ivsimpcmp “-f source"



STEPS FOR SIMULATING USING 
NCSIM

• Source environment variables

For example,

./envsource

--------------envsource file contents--------------------------------------

#setenv CDS_INST_DIR <cadence installation directory>

setenv CDS_INST_DIR /cad_tools/LDV5.1

setenv ittsimUndertowSeDir $CDS_INST_DIR/tools/dfII/local/undertow

setenv LD_LIBRARY_PATH /usr/lib:/usr/openwin/lib:$CDS_INST_DIR/tools/dfII/

lib:$CDS_INST_DIR/tools/inca/lib:$CDS_INST_DIR/tools/lib:$CDS_INST_DIR/to
ols/

lib:$CDS_INST_DIR/tools/verilog/lib:/usr/dt/lib:/usr/lib/x11:/usr/ucblib:/usr20/dt_c
de/lib:/usr/

local/lib/gcc-lib:/usr/local/lib:{SILOS}/bin:$UT_ROOT_DIR/PLI
envsource contd.



NCSIM contd.

envsourcecontd.

For Undertow versions 1.7 and up, please use the correct PLI according to the simulator 
type and version. 

$UT_ROOT_DIR has the following :

ibpli.so.nc_verilog for NC Verilog . This is for CADENCE LDV versions 4.1, 5.1, 5.2
and up libpli.so.old_nc_verilog for CADENCE LDV versions earlier than 4.1
libpli.so.verilog_xl for Verilog-XL

Make sure you do the following:

%cd $UT_ROOT_DIR/PLI/

%cp <appropriate libpli.so.#> libpli.so

Also make sure LD_LIBRARY_PATH has $UT_ROOT_DIR/PLI in the path

• vt_veriuser.c and vtplinc.o are available in our PLI directory.



NCSIM contd.

• <source> is the file that contains the source code files for Simulation

• To make the source file: add iv.v (in our distribution directory) at the top with top 
level file next followed by all the .v files needed in simulation

• Contents of  iv.v file

// iv.v 

module vtInteractive;

initial

$vtIv;

endmodule



NCSIM contd.

• Add to source code close to top module

initial

begin

$vtDumpvars();  /*dumps everything - created by our PLI routine.*/

end

• In the example(in our distribution directory), the above has been inserted in 'top.v' file.



NCSIM contd.

• If you are compiling your design through the simulator for the first time, follow these 
steps:

a) Run "ncprep"

ncprep -f source

-f <file> : used to specify file that contains all the user verilog files. Here, 'source' is 
a file with all of the user's Verilog files(top.v, fsm1.v, fsm2.v, fsm3.v) and iv.v

iv.v is available in the example directory.

Note that ncprep will generate the following files and directories.

- cds.lib

- hdl.vars

- INCA_LIB

- ncvlog.args

- ncelab.args

- ncsim.args



NCSIM contd.

b) Run "ncvlog"

ncvlog -f ncvlog.arg

c)Add the following line into file "ncleab.args"

-ACCESS +RCW

d) Run "ncelab"

ncelab -f ncelab.args

e) Run "ncsim"

ncsim -f ncsim.args



NCSIM contd.

• You can then compile through the simulator again as follows:

./run_ncsim

---------run_ncsim contents---------------------------------------------

#!/bin/csh -f

# Run the NC-Verilog parser (compile the source)

ncvlog -f ncvlog.args

if ($status != 0) then

exit

Endif

# Run the NC-Verilog elaborator (build the design hierarchy)

ncelab -f ncelab.args

if ($status != 0) then

exit

Endif

run_ncsim contd.



NCSIM contd.

run_ncsim  contd

# Run the NC-Verilog simulator (simulate the design)

#ncsim -f ncsim.args +VTCOMPRESS250 +VTVECTORVALUES

ncsim -f ncsim.args

-----------------------------------------------------------------------------

NOTE: +VTCOMPRESS250 +VTVECTORVALUES will compress the size 0



NCSIM contd.

• Viewing the NC Sim Waveform in batch mode, the commands are as follows:

ut -iv -f <source_code_file> -sigfile <signal_file>

source_code_file is the file that lists all the source code files.

For example,

ut -iv -f source -sigfile fsm.sigs

To view just the waveform,

ut -v <signal_file>

For example,

ut -v vt.dump



NCSIM contd.

• Viewing the NC Sim Waveform in interactive mode, the commands are as follows

a) Cadence Verilog-XL

ut -iv -xl verilog -f <file that lists all source code filenames> -sigfile
<signal_filename>

For example,

ut -iv -xl verilog -f source -sigfile fsm.sigs 

b) Cadence NC Verilog-XL

ut -iv -ncxlmode ncxlmode -f <file that lists all source code filenames> -sigfile

<signal_filename> 

For example,

ut -iv -ncxlmode ncxlmode -f source -sigfile fsm.sigs



NCSIM contd.

c) Cadence NC Verilog

ut -iv -nc ncverilog “-f <file that lists all source code filenames>” -sigfile
<signal_filename> 

For example,

ut -iv -nc ncverilog “-f source” -sigfile fsm.sigs

d) Cadence NC Sim (Compiled Simulator)

ut -iv -ncverilog ncsim "-f ncsim.args" -sigfile <signal_filename> -ivsimcmp "-f 
<file that lists all source code file names>"

For example,

ut -iv -ncverilog ncsim "-f ncsim.args" -sigfile fsm.sigs -ivsimcmp "-f source"

OR

ut -iv -ncverilog ncsim worklib.top:v -sigfile fsm.sigs -ivsimcmp "-f source"



Running Simulations

• After running the commands 
from the previous section to 
view those commands

• From the Source Code 
Window menu choose:

• Session => Source Code 
Files/Simulator Options

Simulator 
Option 

Window



Running Simulations contd. 

• Check for design files in the “Design 
Files/Simulator Compile Options:”
text area and simulator executable in 
“Simulator Executable” text area

• Press Apply then Run

• Or from the Source Code Window 
menu choose:

• Simulator => Run

Simulator 
Executable

Source Files

Simulator 
Type



Running Simulations contd.

Undertow Suite

Simulator 
Running

Source Window



Running Simulations contd.

• Click on the “Action”
button to display the list 
of commands for 
running the simulator

• Select “Go 3000 then 
stop”

• The simulator will run 
3000 time points and 
stop

• This action has set the 
first break point at 3000 
time point

Action



Running Simulations contd.

• To further run the 
simulator select the 
options from the 
“Action” buttonSimulation Stopped 

At 3000 Time 
points

Waveform Displayed



“Action” Button 

• To change the definition of the options 
in the “Action” list 

• From the Source Code Window menu 
choose:

• Session => Button

• Print the text in “Button Label” text 
area and simulator command in “Text 
To Send To Simulator” text area in the 
“Button Definition” window

• Press Apply

Label

Simulator 
Command



Finish Simulation

• To finish the simulation 
click on “Finish” from 
the “Action” list

• This will exit the 
simulator after it has 
finished the given time 
points

Finish



History

• Click on “History”
button to display the 
list of previous 
executed commands. 

History
Button



Command Line

• To type the commands 
for the simulator use 
command line window

• Press “Enter” after typing 

the command

Command Line
Window



Regaining the simulator

• To re-run the 
simulator after a 
simulation has 
exited 

• From the Source 
Code Window 
menu choose:

• Simulator => Run

• This will restart the 
simulator from 0 
time point

Run



Run For

• To run the simulation 
for  given time points 

• From the Source Code 
Window menu choose:

• Simulator => Run For 
a Time

• Enter the time point in 
“Simulate For Time”
text area and press 
“Apply”

Enter The 
Time Points



Run For

• This will run the simulator 
for the given time points and 
wait for next command

• This action has set the break 
point for the given time 
points

• To run the simulator without 
breakpoints type “.” in the 
command line window and 
press “Enter”

• Or from the Source Code 
Window menu choose:

• Simulator =>  Continue



Reset Simulator

• To reset the simulator 

• From the Source Code 
Window menu choose:

• Simulator => Reset

• Press “Reset” in the “IV 
Question” windowReset



Reset Simulator

• This will reset the 
simulator

• After the simulator has 
been reset, to access 
module (signal) 
hierarchy, select the 
option to simulate for a 
giver amount of time,  
from the “Action” list 
or give a command 
from the command line 
window

Simulator 
Reset

No Waveforms
No 

Signals

“-”
No Module 
Hierarchy



Reset Simulator

• Giving the command 
to simulate for a given 
amount of time will 
give the access back 
to the module 
hierarchy

“+”
Module 

Hierarchy



Stepping Source Code

• Stepping the Source Code

• “Step Backward” will step 
back through the prior 
simulation steps that are in  
the trace file

• If you are at the last 
simulation time, clicking on 
“Step Forward” will step the 
simulation further

If you are not at simulation 
“current time”, stepping 
forward will step forward 
through simulation steps 
currently in the trace file.

Step 
Forward

Step
Backward



Trace Window

• To display the trace 
window 

• From the Source 
Code Window menu 
choose:

• Tools => Trace

Trace



Trace Window

• The cursor on the 
trace window will 
point to the same line 
as the line of 
execution in the 
source code window

Trace Window

At The Same Line
In Both Source & 
Trace Window 



Setting Breakpoints 

• To Set the breakpoint from 
the “Source Window”

• From the Source Code 
Window menu choose

• Window => Open Window 
-> BreakpointBreakpoint



Breakpoint Window

Break Point Window



Adding Breakpoints

• To set the break point  
Left click the mouse 
button on the line number 
in the “Source Code 
Window”

• “Red” color will indicates 
an active break point

• The list of breakpoints will 

appear in the “Breakpoint
Window”

Breakpoint

“Red” Active 
Breakpoint



Adding Breakpoints

• Doing a continue by 
typing a “.” in the 
command line 

• Or from the Source Code 
Window menu choose  
Simulator => Continue 
will cause the simulator to 
stop at the break pointBreakpoint 

Hit

Mark The 
Simulation 

Time



Disable & Deleting Breakpoints

• To disable the 
breakpoint select the 
breakpoint in the 
“Breakpoint Window”

• Click on “Disable”
button and then press 
“Apply”

• “Green” on the 
breakpoint line in the 
“Source Window”
indicates disabled 
breakpoint

• To remove the 
breakpoint select the 
breakpoint in the 
“Breakpoint Window”
and press “Delete”

Disable

“Green” Disable 
Breakpoint

Apply

Delete

Selected Signal



One Shot Breakpoint

• “One Shot” allows the breakpoint 
to be hit only once during the 
given simulation time

• “Continuous” stops the 
simulation every time it reaches 
that breakpoint(default is 
“Continuous”) 

• To set the One Shot on the 
breakpoint select the breakpoint 
from the “Breakpoint Window”
and select “One Shot” button

• “Yellow” indicates a One Shot 
break point

• If problem setting the One Shot 
toggle “Enable” and “Disable”
buttons in the “Breakpoint 
Window”

“Yellow” One Shot 
Breakpoint

One 
Shot

Continuous



Alter Signal

• Alter Signal allows the 
user to change the 
current value of the 
signals for the 
proceeding simulations 
only

• From the Source Code 
Window menu choose

• Window => Open 
Window -> Alter Signal

Alter Signal



Alter Signal

• Select the signal and drag 
and drop it in the text area 
for the “Signal” in the 
“Alter Signal Value”
window

• Enter the new value for the 
signal for the proceeding 
simulations

• Press “Apply”

Signal Name

Signal Value



Inspect Signal

• To view the new changes in 
the value of the signal 

• From the Source Code 
Window menu choose

• Window => Open Window -
> Inspect Signal

• Select the signal and drag and 
drop it in the text area for the 
“Signal” in the “Signal 
Inspector” window

• Press “Update”

• The new value of the signal 
at the current time will be 
displayedNew Value “1”

Past Value “0”

Simulation Time



Trace Window

• “Simulation Trace Window”
allows to move to next 
simulation point by using 
“Step Forward” button if 
you are at the last simulation 
time point 

• Or to move backward in the 
past simulation time by 
using “Step Backward”

• To move forward in the past 
simulation use “Step 
Forward”

• If the simulator is running 
and last time point in 
simulation is reached 
clicking on “Step Forward”
will advance the simulation 
one step further

Modifies Selected 
Signal

Step Forward



Source & Trace Window 
Synchronization

• To force the “Source 
Window” to be at the 
same point in simulation 
as “Trace Window” click 
on “Open Source File”
button

Open Source File

Mark The 
Cursor Positions



Trace - Breakpoints

• To add the breakpoint in 
the “Simulation Trace 
Window” at the given 
cursor position

• Click in “Breakpoint On 
Line” button

Breakpoint On 
Line 

Breakpoint Added



Virtual Trace

• To view the trace file when 
the simulation is not running

• From the Simulation Trace 
Window menu choose:

• File => Open Trace File …

• Select the desired “.trace” file 
and click “Ok”



Simulator Window

• To view the Simulator 
Window in the “Source 
Window”

• From the Source 
Window menu choose:

• Window => Details 
Window -> Simulator

Simulator



Simulator Window

Simulator 
Window

Command Line 
Window For 

Simulator 


