
 

 
VERITOOL’S TUTORIAL FOR USING VWAVE AS A MIXED MODE DISPLAY 

MIXED MODE WITH VWAVE 
 

 

 

This tutorial demonstrates the use of the Veritools 
vWave software in a mixed mode, both analog, digital 
and mixed analog/digital debugging environment. 

 



To start the vWave Mixed mode tutorial got to the file, 
analog, in the directory examples in your software 
distributions directory 

 
In this directory select the file anja.dump.fast to bring 
in by pressing the following menu items: 

File -> Open File -> anaj.dump.fast 

Your vWave window will look as shown in the next 
figure after you select the anja.dump.fast file.  



 
The vWave window has menus items listed across the 
top of the display window, icon buttons are displayed 
just below these menu items, an area for listing the 
displayed signal names on the left side of this window 
just below the icon buttons. To the immediate right of 
the signal displayed signal list is the area that displays 
the value of the T0/Y0 cursor, and to the right of this 
the waveform display area. At the bottom of the 
vWave window is the area for the design hierarchy, 
with module names listed on the left and the signal 
names on the right.  

Next select the module name s85. This will list all of 
the signals that are in this s85 module as shown below: 

 

 



Also note the pointer is pointing at the name of the file 

currently that is active in the design hierarchy window. 
When more than one waveform file is loaded to the 
vWave, the user can select which file is to be made 
active in the design hierarchy window. 

Using the left mouse button, users can select signal 
names in the signal name area to be displayed in the 
waveform area. The selected names are highlighted 
with a white background. 



 
Also note in this display, the location for hierarchy icon 
for the “Display” icon is shown. Pressing this icon down 
will display all of the signals that are currently 
highlighted, turn off the highlight and add a “*” to 
each signal name in the signal selection area that has 
just been display so users will know if any signal in this 
area is already on the waveform display. When the 
selected signals are displayed, the signal names are 
listed in the signal names list of the left of the display 
window, along with a number at the front of the name, 
1,2, 3, etc., and the file names indicating the file each 
signal came from, as shown below: 

 



Also note the values in the Y0/T0 area are initially at 
time zero, until the users sets a new value in the Y0/T0 
cursor.

 
 

 



Next to now bring in analog file, do the following to 
select this file: 

File -> Open Additional File. This will bring in a new file 
selection window as shown below: 

 
Now in this window select the analog file as 
highlighted. Note that fast files can be made when 
selected files are brought in, using the icon shown 
above, “Create and Load Fast File”, or using vdump a 
batch tool that will quickly make fast file in a batch 
process. A typical vdump command would be:  

%vdump -Cxn vcd.file, which will become vcd.file.fast  



 
This cursor now points to the active file name text area 
that holds name of the file that is now the active file 
for the current hierarchy window. 

Users can select any file in the Active Signal Name text 
area to now make that the file active in the vWave 
window. 

Now select “network’ to display the signal names for 
the analog design in hierarchy “network”. 

 

 



 
This will list the signal names for the analog module 
“network” as shown below:  

 



Next sliding the left mouse over the signal names you 
want to display. 

 
Then press display, as shown by the pointer, to add 
these signal waveforms to the already present digital 
waveform display: 

 



 
Note that when adding analog into a digital waveform 
display the horizontal scale for the analog file must be 
“Time” and note that even if the horizontal scale is 
time the analog can have a different time period for 
the simulation than the digital as show above.  

 



To show the complete analog simulation synchronized 
in time, zoom the analog waveforms by pressing the 
right mouse button down on the waveform display 
window above and to the left of where you want to 
zoom, and slide the cursor down and to the right over 
the signals you want to zoom into. The result display 
will then look as shown below: 

 
In addition to adding the analog right onto the 
waveform display with the digital, you can also add a 
new pane, and have the analog added to just that 
pane. To add a new time pane, do the following: 

Window -> Panes -> Add New Pane, Time 



 
The result is shown below: 

 
Next select the Choose icon to add a signal selector to 
this waveform window: 



 
 

This will bring in a signal selector for the new analog 
file as shown below: 

 



Then select the analog signal you want on this pane: 

 
Make sure the new pane is the active pane, if the “T” 
(which stands for time), in the upper left hand corner 
of each pane for the new pane does not have a Yellow 
back ground select it to make this pane active.  



 
Then press Display as shown below to display the 
selected signals in the new time pane. 

 



The resultant waveform display will look as shown 
below after display is pressed: 

 
These panes can be synced together in two different 
ways, by syncing on the start and end points of the 
horizontal scroll bars, which keeps the zooms the same 
or by syncing on the middle of the horizontal scroll bar 
which allows the zoom setting to be different between 
these panes. 



 
The above figure shows the display windows synced 
with start end points the same. Note that the top time 
scales between these Panes are identical, as can be 
seen in the following figure: 



 
Next add a *ac0 file to the waveform display by 
selecting this file from the list of files in the analog 
directory as shown below: 

 

 



Next select the csdf.ac0 file and press “Add to open 
Files”. 

 
Select signals again, by pressing down the right mouse 
button and dragging this over the signal names you 
want to see on the display: 



 
Note that when a file that does not have a time base 
for its horizontal scale is brought into the waveform 
display that currently has only time based files, a new 
non-time pane, an Arbitrary X Scale Pane is 
automatically added to display these new signals as 
shown below: 



 
Pressing full zoom, will display the full simulation 
waveforms for these newly selected signals. 

 



At this point we have a digital, Verilog, waveform file in 
vWave, an analog *.tran file in vWave, and a *ac0 file 
in vWave. Users can use the middle mouse button to 
drag any signal name in any pane to any other pane 
that has the same horizontal scale to display this signal 
in that pane. Next load in a *.dc0 file by selecting and 
loading this file as shown below: 

 
Select the csdf.dc0 file as shown above and press “Add 
to Open Files”. Next select the signals from this 
csdf.dc0 file as shown below. 



 
Before pressing Display, add a new pane with an 
Arbitrary horizontal scale as follows; 

Window -> Panes -> Add New Pane, Arbitrary X 

  



Then press Display, the resultant vWave display is 
shown below: 

 
The bottom pane holds the just added csdf.dc0 file, the 
csfddf.ac0 has been taken out to allow room to display 
the csdf.dc0 file. When users are adding new panes, if 
there are too many panes to fit the current display 
area, the vWave will automatically scroll the new pane 
so it is visible.  Users can scroll up or down to see all of 
the current panes in vWave.  

 

As part of the vWave waveform display software, users 
have a very complete set of analog analysis features. 



As shown below first select the signal you want to 
analyze. 

 
Then zoom into the area of the signal that you wish to 
analyze. Again with right mouse button, press down 
and slide down and to the right over the area of the 
signal you want more detail on. 

Set the t0 mouse cursor on the left point of the area 
you want to analyze and then set the t1 cursor, the 
middle mouse, on the right side of the area you want 
to analyze, as shown below: 



 
Next open the drop down menu for Analog Analyzer, 
and then select “Rise Time Analyzer” as follows; 

Tools -> Analog Analyzer -> Rise Time Analyzer 

and shown below: 



 
The resultant rise time will be displayed in the Rise 
Time Analyzer window shown below: 

        



vWave also provides hundreds of  analog analysis 
functions in the menu seletcion, “Analog Functgions”. 
To use these functions do the following to select the 
Analog Functions: 

Tools -> Analaog analyzer -> Analaog Functions … 

 

 
As shown below there are hundreds of avaialble analog 
functions users have with vWave when analysizing 
their analog design, functions that can be combined 



with the operators “+”,“-“, “*”, “/”, “<”, “>” to make  
even more complex functions which can be saved if 
they are going to be used more than once.  

 

 

 



To demonstrate these functions, we will add two 
signals together and add this new signal back to the 
display window; 

Drag the signal names you want to add together from 
the waveform display to the Analog Expression area of 
the Analog functions window.  Then select the “+”, 
operator, and place this operator between the signal 
names. Next provide a new signal name in “Name” 
area of this window for this new signal,  

 
When you press Apply the resultant waveform display 
will appear as shown below with the new signal 
“Add_Two_Signals”:   



 

As can be seen if the figure below the Analog functions 
are very extensive and include the transcendental 
functions, SIN, COSIN, TAN, etc., FFT and IFFT 
functions, DFT, GUI Filter builders and many others. 

 

 



In addition to the Analog Functions, the Veritools 
vWave has a script tool based on Perl. Script tool is 
even more useful and powerful because it can extend 
the functions in vWave by the user using the standard 
Perl language, and can be used with either analog and 
digital analysis.  

The Script tool is found in Tools -> Script tool and has 
the initial startup window shown below: 

 

 

 

 

 

 

 

 

 

 

 



The Perl Operators are listed on the left side of the 
window, the Perl Keywords, to the immediate right of 
the Operators field. These are the standard Perl 
operators and Keywords used in standard Perl scripts.  
The Perl functions are listed to the immediate right of 
the Keywords. The Perl functions allow Perl to 
communicate with the vWave software.  

On the right side of the scripts window is the list of the 
Scripts, which are the Veritools defined scripts. 

In the vWave software distribution directory are three 
files that are used to define the Perl operations: 

Undertow.pm, a file that lists the and defines the new 
Perl “Function” routines that connect Perl to the 
vWave software. For example, two of the functions 
are; 

CloseAllFilesAndOpen(Filename) – this closes all files 
currently in vWave and opens and loads the file with 
the specified name.  

CreateAnalogSignal(signal_name, expression) – creates 
an analog signal with the specified name using the 
specified analog functions expression. Any expression 



available in the Analog Functions window can be used 
in an expression for CreateAnalogSignal. 
 

All of these functions are listed in the Perl Functions 
list in the Script window, and are defined as to what 
each function does and the inputs that are required for 
this function in the Undertow.pm file. 

UndertowPerlUtilities.pm is a list of Perl routines that 
are used in building the Perl scripts in the “Scripts” list. 
These routines are based on standard Perl and do not 
require any knowledge of vWave.   

UndertowAnalogExtensions.pm is a file of Perl routines 
used primarily for creating analog scripts. Examples are 
Average, FindNDBPoints, GetPeriod, GetFrequency, 
etc.  

For example, in “FindNDBPoints”, N defines a DB point 
the user wants to find on a signal. If N is set to a -3, this 
routine will find the maximum value of this signal and 
then find the 3DB down point on this signal from this 
maximum value.   



The routines in Undertow.pm, 
UndertowPerlExtentions.pm and 
UndertowAnalogExtenrtions.pm along with the Perl 
Operators and Keywords were used to write the Perl 
code for the Scripts in the Scripts list.  

Scripts in the Scripts window are located with the 
environment variable UT_SCRIPTS_DIR, which is 
usually set to $UT_ROOT_DIR/scripts, with the script 
routine suffix defined in the 

Script_Tool -> Window -> Configure-> File Suffix: text 
area, currently set to “. script” Users can add their own 
routines to the Scripts directory, the 
UndertowPerlExttentions.pm and the 
UndertowAnalogExtentions.pm files.  

Since most engineers are familiar with C programming 
and Perl, the Script tool allows the vWave to have 
unlimited extensibility defined by the user with an easy 
to use universal language.    

The currently available Scripts are the following: 
3DB.script                   
Amplitude.script             
analogdev.script             



AtX.script                   
Average.script               
bandpass.script             
Baseline.script             
builder.script             
bus-interpeter.script       
compare_files.script        
compare_module.script        
compare_module_tree.script  
compare_signal.script        
dbdown.script               
deltax.script               
DeltaX.script      
DeltaY.script                    
dutycycle.script          
dutycycle_vs_time.script   
get_values.script        
highpass.script                               
localmax.script           
localmin.script       
lowpass.script           
low_to_high.script  
MaxFall.script           
MaxPoint.script          
MaxRise.scrip 
meas_gui.script 
measgui.script 
measure1.script 
measure.script 
MinPoint.script 
PeakToPeak.script 
place_tag.script 



ScriptsMenu.script 
SlewRate.script 
stopband.script 
threshold.script 
Topline.script 
up_cvs_test.script 
ut.test.script 
xmax.script 
xmin.script 
 
Examples of some of these scripts are as follows: 
 
3DB.script 
 
# This script finds the 3 DB points with respect to maximum value point.  
# It selects the first point and adds the value tag to indicate that 
# it is the 3 DB point. 
 
use UndertowAnalogExtension qw(FindNDBPoints GetFirstMaxPoint 
GoToAtTime); 
use UndertowPerlUtilities qw(NDBValue); 
 
my(@signals, $signal, $max_point, @result); 
@signals = GetSelectedSignals(); 
$signal = $signals[0]; 
 
$start = GetCursor(0); 
$end = GetCursor(1); 
print "start = $start   end = $end    \n"; 
 
$max_point = GetFirstMaxPoint($signal, $start, $end); 



 
@result = FindNDBPoints($signal, $start, $end, $max_point, 3, 0); 
print "3 DB points are: @result  \n"; 
 
GoToAtTime(0, $signal, $result[0]); 
PlaceValueTagUsingCursor("3 DB Point $result[0]"); 
 
Amplitude.script 
 
#This script finds the amplitude of a selected signal. 
 
use UndertowAnalogExtension qw(FindNPeaks GetFirstSameValuePoints 
PrintVarArray); 
 
my(@signals, @data); 
@signals = GetSelectedSignals(); 
 
$start = GetCursor(0); 
$end = GetCursor(1); 
print "start = $start   end = $end    \n"; 
 
print "Selected signal is $signals[0]   \n"; 
 
my(@result, $top_line, $base_line, $amplitude); 
@result = GetFirstSameValuePoints($signals[0], $start, $end, 1, 1); 
$top_line = $result[2]; 
 
@result = FindNPeaks($signals[0], $start, $end, 2); 
#PrintVarArray(@result); 
$base_line = $result[9]; 
 
$amplitude = abs($top_line - $base_line); 



 
print "Top line: $top_line  Base line: $base_line  Amplitude: $amplitude  
\n"; 
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